Reference Information

Playing back DSD audio using foobar2000
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NOTICE

e “foobar2000” is not Yamaha product. Yamaha cannot be held responsible for any damages arising out of the use of the software.

e “foobar2000” is installable only on Windows computers. The procedures described in this documentation are based on Windows 7.
e The documentation is based on information as at May 2013 (We have no plans to offer updates).

Required components

foobar2000

“foobar2000” is an advanced freeware audio player for Windows. By installing foobar2000 and other components on your Windows
computer, you can enjoy DSD (Direct Stream Digital) audio playback on the unit (via USB DAC).

Yamaha Steinberg USB Driver
Driver software required for connecting a device compatible with Yamaha Steinberg USB Driver to a computer.

ASIO support
A component required for DSD audio playback on foobar2000.

Super Audio CD Decoder
A decoder required for direct DSD playback of Super Audio CD ISO images, DSDIFF and DSF files on compatible devices.



Installing foobar2000

1 Download the latest stable version of foobar2000 at the following website.
http://www.foobar2000.org/download

2 Double-click the downloaded file “foobar2000_v*.*.*.exe” to start installation.

3 Follow the on-screen instructions to install the software.

Installing Yamaha Steinberg USB Driver and

configuring its settings

1 Download “Yamaha Steinberg USB Driver” at the
following Yamaha website.

http://download.yamaha.com/

2 Install “Yamaha Steinberg USB Driver” on your
computer, connect the unit to your computer,
then open its control panel.

For details on the installation and how to open the
control panel of the driver, refer to the Installation Guide
supplied with the driver software.

For details on the connection, refer to the Owner’s
Manual of the unit.

3 Configure the following control panel settings.

* “ASIO” setting &4 Yamaha Steinberg USB Driver
Device: Yamah B DA
evice: Yamana USB DAC ASIO [ about

Device :
Buffer Size : 512 Samples hd
Input Latency : 15.601 msec
Qutput Latency : 18.594 msec

* “Yamaha USB DAC” setting &4 Yamaha Steinberg USB Driver

Sample Rate: 176.4 kHz —'—I—l‘famaha USB DAC [a510- | About

Sample Rate :

Cancel

4 ciick [OK].
Installation and settings of “Yamaha Steinberg USB
Driver” is now completed.


http://download.yamaha.com/
http://www.foobar2000.org/download

Installing the “ASIO0 support” component

'l Download the “ASIO support” component
(foo_out_asio) at the following website.

http://www.foobar2000.org/components/view/
foo_out_asio

2 Run foobar2000, then select [File] > . foobar2000 v

[Preferences]_ File | fdit View Playback Library Help | [] [> [ K B [ —)
Open... Ctrl+0
Bpes R Trackno Title / track artist Durat...
Add files...
Add folder..
Add location... CtrlsU
New playlist Ctrl+N
Load playlist...
Save playlist... CtrleS
o+
Exit

. i ‘ - .
3 Click [Components] - [Install]. Preferences: Components e
Companents lled Right-click a component for additional options
p—r Neme ’ Version Modue
e Abum List 45 foo_albumist
Networking CD Audio Decoder 3.0 foo_cdda
- -Playback Converter 15 foo_converter
Shel Integration Default User Interface 0.9.5 foo_ui_std
- Advanced Equalizer 1.0 foo_dsp_eq
foobar2000 core 126 Core
ReplayGain Scanner 2.2 foo_rgscan
Standard DSP Array 12 foo_dsp_std
Standard Input Array 10 foo_input_std
Get more components
Why are some components arayed out? l Instal... .MJ Get updates
S— ;J
Resetall Reset page oK Cancel Apply
_
Name Date modified Type Size
4 Select the downloaded component -
« . ” . I‘ﬁfoo,out,asm.fb}.krcomponentl 2013/05/15 14:42 foobar2000 Comp... 183KB
foo_out_asio.fb2k-component”, then click
[Open].
1me: foo_out_asio.fb2k-component -



http://www.foobar2000.org/components/view/foo_out_asio
http://www.foobar2000.org/components/view/foo_out_asio

5 ciick [Apply].

6 In the dialog box, click [OK] to restart
foolbar2000.

7 i foolbar2000 is restarted, click [File] >
[Preferences] > [Components], then confirm
“ASIO support” is listed in “Installed
components”.

Installation of the “ASIO support” component is now
completed.

Preferences: Components

e

Components
> -Display
Keyboard Shortauts
b -Media Library
Networking
> -Playback
Shell Integration
- Advanced

lled Right-cick a component for additional options.
Name Version Module
Album List 45 foo_albumlist
CD Audio Decoder 3.0 foo_cdda
Converter 15 foo_converter
Default User Interface 095 foo_ui std
Equalizer 10 foo_dsp_eq
foobar 2000 core 126 core
ReplayGain Scanner 2.2 foo_rgscan
Standard DSP Array 12 foo_dsp_std
Standard Input Array 1.0 foo_input_std
(unknown - please apply changes toload) (unknown) _foo_out_asio

Get more components
Why are some components araved out?

Resetall | | Resetpage

oK concel ) [ apoiy

Copyreport | |Get updates
pe—

s

foobar2000 preferences

S=X)

Applying these changes requires foebar2000 to be restarted. Continue?

oK Cancel

Preferences: Components

e

Components
> -Display
Keyboard Shortauts
b -Media Library
Networking
> -Playback
Shell Integration
- Advanced

lled Right-cick  component for sdditional options.
Name B Version Module
e . PR
ASIO support 212 foo_out_asio
Converter 15 foo_canverter
Default User Interface 0.8.5 foo_uistd
Equalizer 10 foo_dsp_eq
foobar 2000 core 126 core
ReplayGain Scanner 2.2 foo_rascan
Standard DSP Array 12 foo_dsp_std
Standard Input Array 10 foo_input_std

Get more components
Why are some components araved out?

Resetall | | Resetpage




Installing the “Super Audio CD Decoder” component

II Download the latest version of “foo_input_sacd- Loaking for the latest version? Download foo_input_sacd.0.6.4.zip (442.2 kB)
0.*.*.zip” at the following website. Homs ! foo_input. sacd 5
http://sourceforge.net/projects/sacddecoder/ Name # Modified ¢ Size ¢ Downloads ¢
files/foo_input_sacd/ © Premilis
Ifnn_input_sacd-D 6.4zip [i}] ] I
foo_input_sacd-0.6.3 zip ]
foo_input_sacd-0.6.2.zip 0
foo_input_sacd-0.6.1.zip ]
foo_input_sacd-0.6.0 zip 0
foo_input_sacd-0.5.11.zip 0
2 Uncompress the downloaded file
“foo_input_sacd-0.*.*.zip".
3 In the uncompressed folder, double-click . filters
“ASIOProxylnstall-0.*.*.exe” to start installation.
| EIC
7] ASIOProxylnstall-0.6.3.exe
|%| foo_input_sacd.dll
|| readme.td
4 Follow the on-screen instructions to install the
component.
5 Run foobar2000, then select [File] > [Preferences]. 2 fo0bar2000 v
File | [Edit View Playback Library Help O 0mKHE —)
Open... Ctrl+0
Open audie CD... Track no Title / track artist Durat...
Add files...
Add folder...
Add location... Ctrl+U
New playlist Ctrl+N
Load playlist...
Save playlist... Ctrl+§
Exit
6 click [Components] > [Install]. Prferences Componerts B
I Components I Installed components: Right-click a component for additional options
Name . Version Module
- :Z:?:E:f:'ﬁ”“ Album List 45 foo_albumist
Networking ASIO support 212 foo_out_asio
> -Playback CD Audio Decoder 3.0 foo_cdda
Shell Integration Converter 15 foo_converter
Advanced Default User Interface 0.9.5 foo_ui_std
Equalizer 1.0 foo_dsp_eq
foobar 2000 core 1.2.6 Core
ReplayGain Scanner 2.2 foo_rgscan
Standard DSP Array 12 foo_dsp_std
Standard Input Array 0 foo_input_std
E%ﬁ%@m l Install... Copy report | | Get updates
S—
Resetall Reset page oK Cancel Apply



http://sourceforge.net/projects/sacddecoder/files/foo_input_sacd/
http://sourceforge.net/projects/sacddecoder/files/foo_input_sacd/

7 Select the downloaded component
“foo_input_sacd-0.*.*.zip”, then click [Open].

8 click [Applyl.

9 In the dialog box, click [OK] to restart
foolbar2000.

1 0 If foolbar2000 is restarted, click [File] >
[Preferences] > [Components], then confirm
“Super Audio CD Decoder” is listed in “Installed
components”.

Installation of the “Super Audio CD Decoder”
component is now completed.

Name

Date modified Type

Size

N fooinput sacd-054.ip ||

2013/05151851  Compressed (zipp..

432 KB

me: foo_input_sacd-06.4.zip

~ |foobar2000 compenents (foo
Open |+] Cancel

Preferences: Components

e

Components
> -Display
Keyboard Shortauts
b -Media Library
Networking
> -Playback
Shell Integration
- Advanced

lled Right-cick a component for additional options.
Name Version Module
Album List 45 foo_albumlist
ASIO support 212 foo_out_asio
CD Audio Decoder 3.0 foo_cdda
Converter 15 foo_converter
Default User Interface 0.5 foo_ui std
Equalizer 10 foo_dsp_eq
foobar2000 core 126 Core
ReplayGain Seanner 22 foo_rascan
Standard DEP Array 12 foo_dsp_std
Standard Input Array 10 foo_input_std
(unknown - please apply changes toload) (unknown) _foo_input_sacd

Get more camponents
Why are some components araved out?

Resetall | | Resetpage

oK concel [ apoiy

Copyreport | |Get updates
—

-

foobar2000 preferences

S=X)

Applying these changes requires foobar2000 to be restarted. Continue?

oK Cancel

Preferences: Components

e

Components
-Display

Keyboard Shortauts
b -Media Library
Networking
-Playback

Shell Integration
-Tools

Advanced

lled Right-cick a component for additional options.
Name B Version Medule
Album List 45 foo_albumlist
ASIO support 212 foo_out_asio
CD Audio Decoder 3.0 foo_cdda
Converter L5 foo_converter
Default User Interface 0.5 foo_ui std
Equalizer 10 foo_dsp_eq
foobar2000 core 126 core
ReplayGain Scanner 22 foo_rgscan
Standard DSP Array 12 foo_dsp_std
T . PR
Super Audio CD Decoder 0.6.4 foo_input_sacd | |

Get more components
Why are some components araved out?

Resetall | | Resetpage




Configuring DSD playback settings of foobar2000

1 Click [File] > [Preferences] - [Playback] >
[Output], then select “ASIO:foo_dsd_asio” from
the “Device” pull-down list.

2 Ciick [Output] > [ASIO], then double-click
“foo_dsd_asio” in “ASIO drivers”.

3 Configure the following settings.
ASIO Driver: Yamaha Steinberg USB ASIO
DSD Playback Method: ASIO Native

Fs: DSD64 (normal speed playback) or DSD128
(double speed playback)

4 Click [X] (close button) to close the window.

5 Click [Tools] > [SACD], configure the following
setting.
ASIO Driver Mode: DSD

6 click [OK].

DSD playback settings of foobar2000 is now
completed.

You are ready to enjoy DSD audio playback on the unit.

-
Preferences: Output

~Components
> -Display

~Keyboard Shortcuts
> -Media Library

4 Playbadk
~-Ehel Integra ton

» -Tools
- Advanced

Device

[ps 2 Primary Sound Driver

[ASIO : foo dsd_asio

DS : Primary Sound Driver

DS : Realtek Digital Output{Optical) (Realtek High Definition Audio)
DS : Realtek Digital Output (Realtek Hgh Definition Audio)

DS : Realtek Digital Output {Realtek High Definition Audio)

W/arning; setting too law buffer length may cause some visuslization effects to stop working.

‘Output format

Output data Format Dither

Output data format will be chosen automatically for the selected device,

Fading
Name Fade in Fade out
Pause and stop 100ms 100 ms
Seek 100ms 100 ms
Marual track change 100 ms 100 ms
Automatic track change oms oms

Fade in:

i
i

Resetall Reset page

Fade out:

Apply

-
Preferences: ASIO

> -Display
Keyboard Shortauts
» -Media Library
Networking
4 -Playback
- DSP Manager

4-Tools
t.5ACD
Advanced

Components

ASIO drivers

Iﬁo dd 3o i

Double ick an entry to actvate the driver's control panel.
[7]Use 64-bit ASIO drivers
[C1Run with high process priarity

‘Custom channel

Add New

This feature allews you to configure alternate channel mappings for your ASIO-enabled
soundeards.

‘fou may need to dose and re-open the foobar2000 preferences dialog for your newly
‘added mappings to appear as output devices in the “output” page.

F

foo_ds=d_asio v0.6.3

===

ASIO Driver:

DSD Playback Method:

'Yamaha Steinberg USE ASIO -
=

|10 Native

PCM to DSD Method:

INone LI

Fs: |DsD128 v |

Preferences: SACD

Campanents
> -Display
Keyboard Shortauts
b -Media Library
Networking
4-Playback
£ DSP Manager
4 Output
ASI0

Shel Integration
(- Tools
SACD

ASIO Driver Mod

PCM Volume:

PCM Samplerate: -17ﬁ400
DSD2PCM Mode: | Direct (Double-Precision, 30kHzLF v || Load

save
Preferable Area:

[ Editable Tags
[ Edited Master Playback

) [ Cl=
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